欢迎访问优讯网!
您当前的位置:首页 > 爱编程

基于Python3.7.1无法导入Numpy的解决方式

时间:2020-03-10 10:16:36  来源:优讯网  作者:小卡司  浏览次数:
这篇文章主要介绍了基于Python3.7.1无法导入Numpy的解决方式,具有很好的参考价值,希望对大家有所帮助。一起跟随小编过来看看吧

开发环境:Pycharm 2018.3 + Anaconda3(5.3.0) + Python 3.7.1 + Numpy 1.15.4

在此环境下,我打算使用numpy模块的zeros方法创建一个空的二维List,却屡屡报错

Traceback (most recent call last):
File "D:\Anaconda3\lib\site-packages\numpy\core\__init__.py", line 16, in <module>
from . import multiarray 
ImportError: DLL load failed: 找不到指定的模块。

经过排查后发现并非Anaconda或者Pycharm的问题,在numpy的issue找到了这个线索

这是Pycharm的bug反馈网站,其中一位反馈者在讨论中提到将python降级到3.6即可解决,经尝试,完美解决该bug

在conda环境中可以很方便的降级某一软件的版本,命令如下

# downgrade python in the base enviroment
$ conda install python=3.6.7 
# downgrade python in your own enviroment
$ conda install -n your_env python=3.6.7

补充知识:使用pycharm编辑器编写python出现找不到numpy等包的问题

在python的cmd环境中能正确使用numpy包,但是在pycharm编辑器中确出错找不到numpy包!

这时候只需要在PyCharm的settings中设置一下Interpreter就可以了。如下图所示,

以上这篇基于Python3.7.1无法导入Numpy的解决方式就是小编分享给大家的全部内容了,希望能给大家一个参考

来顶一下
返回首页
返回首页

原文链接:https://www.jb51.net/article/182287.htm


推荐资讯
如何下载旧版centos iso镜像 如何下载迷你mini版的centos镜像
如何下载旧版centos i
计算机的正确使用姿势 电脑痴如何正确的使用电脑
计算机的正确使用姿势
好用的后台管理的前端框架模版H-ui H-ui框架模版分享
好用的后台管理的前端
微信电脑多开方法 无需辅助电脑版微信双开方法分享
微信电脑多开方法 无
相关文章
栏目更新
栏目热门